TVM Android 构建时千万不要用最新的工具!

遇到报错 [INSTALL_FAILED_INVALID_APK: Failed to extract native libraries, res=-2]

修改 AndroidManifest.xmlapplication 字段,添加 android:extractNativeLibs="true" 即可解决问题

<application  
android:extractNativeLibs="true"  
android:allowBackup="true"  
android:label="@string/app\_name"
             ...
             ...

改成 false 也可以

原因是 Android 6.0 以后 so 文件不默认封装在 apk 里

https://testerhome.com/topics/18463

具体注意事项看上面的链接!

具体注意事项看上面的链接!

具体注意事项看上面的链接!

具体注意事项看上面的链接!

因为上面的链接里讲了 extractNativeLibes 设置 true 或 false 都会带来哪些影响以及解决方法以及签名的顺序!

我真想批评一下这些搞科研的人,为什么不能追随新科技呢。

稍微做一下适配,也不会让我们这些后来者因为这些问题踩坑浪费这么多时间吧…

一说起这个我就想起来那些依然在用 python2 的人。

print加个括号就这么难吗?!